Tips & tricks: Excel

Excel: De "0" voor een telefoonnummer verdwijnt steeds

Voorloopnullen toevoegen met TEKST() of TEKST.SAMENVOEGEN()

Als je in Excel nummers invoert in een cel met voorloopnullen, dan zal Excel deze automatisch verwijderen.
Dat komt omdat Excel een rekenblad is, en alle nummers als getallen beschouwt, tenzij jij dat expliciet vraagt.

Stel dat je een lijst hebt met telefoonnummers waar de voorloopnul is weggevallen, dan wil je die uiteraard graag toevoegen:

Je kan hiervoor op 3 manieren te werk gaan afhankelijk van je brondata.

Handmatig aanpassen

Als je enkele nummers moet aanpassen, dan is dit gemakkelijk uit te voeren.

Maar bij meer nummers? Verspil je tijd niet, en gebruik één van de andere manieren.

TEKST()

Deze functie zal voorloopnullen toevoegen, waarbij je wel vooraf de gewenste lengte moet definiëren.

Excel zal dan het aantal voorloopnullen toevoegen dat nodig is.

In ons voorbeeld gebruiken we volgende formule:

=TEKST(A2;"0000000000")

Dit werkt perfect. We vragen aan Excel om tekst te maken van ons getal, met een lengte van 10 karakters.
Gezien alle getallen 9 cijfers lang zijn, wordt overal 1 voorloopnul toegevoegd.

Opmerking: de formule TEKST() werkt enkel op getallen.

=TEKST("opleiding.be";"0000000000")

Deze formule zal resulteren in “opleiding.be”, niet in “0opleiding.be”

TEKST.SAMENVOEGEN()

Maar wat dan als niet alle nummers even lang zijn? Zoals je hier kan zien is onze formule TEKST() niet langer bruikbaar.

Deze situatie kunnen we oplossen met TEKST.SAMENVOEGEN().

We willen overal 1 voorloopnul. Dat doen we als volgt.

=TEKST.SAMENVOEGEN("0";A2)

Met als resultaat:

Tip: je kan deze formule ook inkorten naar:

="0"&A2

ECT BVBA - Oosterveldlaan 211 (2610 Wilrijk) - Tel: +32 (0)3 239 54 67 - Fax: +32 (0)3 281 62 11 -

Erkenningsnummer KMO-Portefeuille: DV.O100387

BTW-nummer: BE 0456.352.435