Tips & tricks: Excel

Gegevens samenvoegen met een functie

De functie is vrij éénduidig, het voegt tekst samen van 2 of meerdere cellen naar 1 cel.

Het voegt dus verschillende tekenreeksen samen tot één tekenreeks met een maximum van 255 fragmenten.
De fragmenten kunnen zowel tekstdelen, getallen of verwijzingen zijn naar een cel.

Zoals je ziet op bovenstaande afbeelding kan je teksten uit verschillende cellen samenvoegen door de functie tekst.samenvoegen te gebruiken. In de formule verwijs je steeds naar de tekstfragmenten (tekstdelen, getallen of verwijzingen) die je wilt samenvoegen.

Gegevens samenvoegen met een functie

De functie ziet er zo uit =TEKST.SAMENVOEGEN(tekst1;tekst2;tekst3;…)

Tekst samenvoegen in Excel kan op verschillende mogelijkheden namelijk:

  • Tekst samenvoegen zonder opmaak
  • Tekst samenvoegen met valuta
  • Tekst samenvoegen met datum

Tekst samenvoegen zonder opmaak

Je zou graag meerdere verschillende stukken tekst in verschillende cellen samenvoegen tot één tekst, zonder opmaak van cijfers of data.

Plaats de cursor waar je het eindresultaat wilt bekomen (B7).
Gebruik de formule =TEKST.SAMENVOEGEN(tekst1;tekst2;tekst3;…)
Concrete voorbeelden:
→ =TEKST.SAMENVOEGEN(“Erik“;" ";”Servaes”) → Erik Servaes
→ =TEKST.SAMENVOEGEN(“ECT biedt cursussen aan zoals:”;”B22″) → ECT biedt cursussen aan zoals: Excel (belangrijk om te weten is dat in cel B22: Excel staat)

TIP:Om spaties tussen de verschillende tekstdelen te plaatsen, maak je gebruik van " " :

Tekst samenvoegen Excel met valuta

Je wil tekst samenvoegen uit verschillende cellen waar getallen in voorkomen. Dit kan gaan over normale getallen of bepaalde valuta.

  • Selecteer de cel waar je de tekst wilt samenvoegen tot één tekst (B7).
  • Gebruik de formule =TEKST.SAMENVOEGEN(tekst1;tekst2;tekst3;…)



  • Wanneer je een een bepaald cijfer met valuta (EURO) wilt toevoegen aan de functie, moet je nog een extra functie toevoegen namelijk: “EURO. De formule luidt als volgt: =EURO(getal; [decimalen])
  • Concrete voorbeelden:
    • =TEKST.SAMENVOEGEN(“lidgeld:”;50) → lidgeld: 50
    • =TEKST.SAMENVOEGEN(“lidgeld”;EURO(50)) → lidgeld: € 50

Tekst samenvoegen met datum

Wanneer je meerdere teksten samen wilt voegen met een bepaalde opmaak voor een datum. Dit kan je door een extra functie toe te voegen aan de formule: =TEKST(waarde; notatie_tekst)

  • Gebruik meerdere stukken tekst die je wilt samenvoegen, gebruik verder ook een datum die je wilt integreren in de formule.
  • Wanneer je beide stukken tekst hebt, gebruik je steeds de formule =TEKST.SAMENVOEGEN(tekst1;tekst2;tekst3;…)



Concreet voorbeeld:

B1 verwijst naar een tekst (Erik)

B2 verwijst naar een tekst (Servaes)

B3 verwijst naar een tekst (lidgeld)

B4 verwijst naar een bedrag (€50)

B5 verwijst steeds naar een datum (20/03/2017l).

=TEKST.SAMENVOEGEN(B1;" ";B2;" ";B3;"van ";EURO(B4);" ";"betaald op";" ";TEKST(B5;"dd/mm/jjjj"))

Voorgaande formule geeft dan "Erik Servaes Lidgeldvan € 50,00 betaald op 20/03/2017"

ECT BVBA - Oosterveldlaan 211 (2610 Wilrijk) - Tel: +32 (0)3 239 54 67 - Fax: +32 (0)3 281 62 11 -

Erkenningsnummer KMO-Portefeuille: DV.O100387

BTW-nummer: BE 0456.352.435